System Requirements

It is mandatory to have the following minimum requirements for the best Avorra experience.

OptionDescription
BrowserGoogle Chrome (Version 48 or above)
Operating systemMicrosoft Windows OS version 7, 8.1 or 10

Apple Mac OS version 10.9 (Mavericks)

*Currently, Avorra does not support IE, Microsoft Edge, Firefox, and Safari web browsers. 

*Avorra does not support iOS or Android devices with small portable screens.